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National Sensor Evaluation (SensorEval) 1.2.0 

 Software User’s Guide 
 
This package includes the SensorEval software and documentation as well as documentation for the evaluation 

board hardware. The ADCS9888, LM32, LM40, LM41, LM63, LM64, LM71, LM73, LM75, LM85, LM86, 

LM89, LM89-1, LM90, LM93, LM99, LM99-1, LM95010, LM95071, LM95172, LM95213, LM95214, 

LM95221, LM95231, LM95233, LM95234, LM95235, LM95241, LM95245, LM96000, LM96063, LM96080, 

LM96163 and ADC128D818 are supported as noted for the following hardware for Windows 2000/XP/Vista: 

1) USB Evaluation Boards (except for the LM93) 

2) Intel ICH interface (except for the ADCS9888, LM32, LM40, LM41, LM71, LM95010, and LM95071) 

3) "No hardware" mode to run the software without any hardware 

 

To view the documentation, Adobe Acrobat Reader 4.05 or later is required (download it from www.adobe.com 

if needed). 

 

I. Installation Steps 
 

1) If using the evaluation board, unplug the USB cable from the board 

 

2) Run SensorEval_1.2.0_Setup.exe  (depending on the media you have, this may be on the SensorEval CD or in 

the SensorEval_1.2.0.zip file) 

 

NOTE: If you previously installed an older version of the software (LmxxEval or SensorEval), you will be 

asked to uninstall it to avoid conflicts. Any log and register files you generated with the older version will be left 

in the original directory if you wish to access them later. 

 

3) If using the evaluation board, plug the USB cable into the board and wait for the board to install. If you are 

installing under Windows XP, the New Hardware Wizard will appear; enter “No, not this time” for Windows 

Update, then “Next”, “Continue Anyway” (you should ignore the Windows Logo warning), and “Finish”. It is 

not required to reboot after the installation. 

 

4) Go to Programs->National Semiconductor->National SensorEval (or use the desktop icon National 

SensorEval) to execute the software. Select the desired device. Under Windows 2000/XP you will be prompted 

to select either the USB evaluation board or the Intel ICH or no hardware mode. (No hardware mode bypasses 

the device connection so that the software can be viewed without any device). Select the desired hardware and 

wait for the software to start. This may take a few seconds the first time the evaluation board is connected. If 

you wish to change the device or hardware later, select the device again under the Device menu.  

 

NOTE: If you are unable to connect to the USB evaluation board and have previously installed a driver for the 

board, do the following to uninstall and reinstall the driver. Go to the Windows Control Panel and select System. 

If you are using Windows 2000/XP select the Hardware tab. Then click on Device Manager and go down to the 

Universal Serial Bus controllers. With the evaluation board connected, you will see it listed. Right click on it 

and uninstall the driver. Then unplug and plug in the board again to reinstall the driver. 

 

NOTE: If you accidentally select an invalid device file and encounter a read/write file error, the workaround is 

to exit the program and edit the lmxxeval.def file in the install directory (typically C:\program files\National 

Semiconductor\SensorEval) to set device=”none”. Then restart SensorEval. 

 

5) To view the documentation for the software or hardware, select Help->Manual. If you have the CD, you may 

also view the documentation there. Datasheets can be viewed at or downloaded from www.national.com. 
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II. Description of SensorEval Software 
 

The interface of the software displays the registers of the selected device. The software remembers the last 

selected device and associated settings and restarts with those values. If the device is not found on startup, the 

device selection dialog will appear. The hardware selection dialog appears next to allow selection of the desired 

hardware (USB evaluation board or Intel ICH or No hardware). It is possible to invoke the software more than 

once, and have different devices displayed at the same time.   

 

Tabs/Buttons/Checkboxes 
 

Upon startup, the register values are read and displayed. To view a particular register, click the tab for the 

desired range of registers. By default, the “Write On Change” checkbox is checked which writes a new register 

value to the device whenever a display register is updated by the user. Also by default, the “Read After Write” 

checkbox is checked which causes all the registers to be read after any write. Thus the display will always 

reflect the current register values of the device. Note that the textbox entries are not considered complete until 

the mouse cursor leaves the box or the enter key is pressed. A special case is the LM63 write-once register 19h, 

which is not written and read back until another register is written or the "Write Regs" button is pressed. Note 

that the "Write Regs" button will be enabled whenever there is an incomplete write operation (for example a 

partial textbox entry). 

 

If desired, the “Write on Change” checkbox may be unchecked. The display then only reflects the state of the 

device after the registers are read. The "Write Regs" button only writes the modified registers. After every write, 

the current register values are read back only if the “Read After Write” checkbox is checked. The state of the 

“Write on Change” and “Read After Write” checkboxes is saved upon program exit or selection of another 

device. 

 

The "Read Regs" button reads all the registers. The "Read Cont" combo box allows continuous reading of either 

all registers or only the value registers such as temperature, voltage, and RPM; the continuous read is at the rate 

selected by the menu item “File->Set Read Time” (the default is one second).  

 

The "Start Log" button allows selection of a log file where the value registers are logged. The register values are 

converted to the appropriate units. The button changes to "Stop Log" when the log is in progress. At the start of 

the log, all the register values are listed, followed by the log data each second. The timing of the read of the log 

data can be modified through the “File->Set Read Time” menu item. The log file can be viewed by the menu 

item “File->View Log”. The log file name is saved upon program exit or when another device is selected. 

 

The "Start Plot" button plots the value registers selected by the “File->Select Plot” menu item. Each plot can 

show multiple value registers of the same type, such as temperature. The button changes to “Stop Plot” while the 

plotting is in progress. The windows may be resized or closed while the plotting is occurring. The timing of the 

plotting can be modified through the “File->Set Read Time” menu item.  

 

The device address of the part is shown for parts with the I2C or SensorPath interface. The label of the combo 

box is “I2C Addr” for the I2C parts, and “Device #” for the SensorPath parts. If multiple addresses are supported 

by the part, they may be selected through the combo box. The value is saved upon program exit or when another 

device is selected.  The value is blank for other interfaces. 
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Register/Bit Field Display 
  

The register display shows bit fields organized by register. Each bit field has the following display data: 

1) Adr  

This is the address of the bit field in hex. This field is blank when the address of the bit field is the same as the 

prior bit field.  

NOTE: This field is also blank for the LM71, which does not have register addresses. 

 

2) Attr  

This shows the attributes of the bit field. R indicates read, W indicates write. Read only bit fields are grayed out 

but may still be written by user entry. Note that some registers are read only if they are locked out by other 

register bits. The register display updates to reflect this. 

 

3) Register Bit Field 

This is the name of the bit field. A bit field may be from 1 to 8 bits. 

 

4) Register Bits 

This shows the bits of the bit field. White bits indicate the bit positions for this bit field. These bits (if not read 

only) may be clicked to toggle the bit. Black bits indicate unused bits for this bit field. The first bit field of a 

register shows the bit values of the whole register.  

NOTE: The LM71 locks out entry for these bits in the configuration register to prevent erroneous value entries; 

the combo box must be used to modify the value. 

 

5) Hex 

This is the register value in hex. The first bit field of a register contains this textbox where the register value is 

displayed or entered. When an entry is made, the value is validated when the mouse cursor leaves the box or the 

enter key is pressed. Valid hex characters (0 to F) must be entered.  

NOTE: The LM71 locks out entry for this textbox in the configuration register to prevent erroneous value 

entries; the combo box must be used to modify the value. 

 

6)Bit Field Value 

These controls may optionally appear and allow optional entry/display of the bit field. They provide more 

detailed information on the particular bit field. There are three possible controls here: 

a) Combo box to display/select the particular bit field value 

b) Textbox to display/enter in decimal either the whole register or only a selected bit field. A textbox on the first 

line of a register is typically for the whole register, while textboxes on following lines are for a particular bit 

field. When an entry is made, the value is validated when the mouse cursor leaves the box or the enter key is 

pressed. Valid decimal characters (0 to 9) or "-" or "." must be entered. 

c) Scroll bar to provide an alternative way to enter the decimal textbox information 

 

Note that the Register Bits/Hex/Bit Field Value fields all update when an entry is made for any of the controls in 

the three fields.  

 

If you want to save and reload the register values, see the menu items “Save Regs” and “Open Regs” below. 
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Menu Items 
  

1)File->Open Reg 

This opens a previously saved register data file. The file name is displayed in the File: field below the menu. 

When you open a file, it is requested if you want to save the current register display values to a file before 

loading the new data. Note that if the "Write On Change" box is checked, the values are automatically written to 

the device after the file is opened. The file name is saved upon program exit or selection of another device. 

NOTE: The file format is not compatible with LmxxEval version 4.07 or older. If you used these versions and 

saved register files, see the change history for a procedure to upgrade your files. 

NOTE: This menu item is not implemented for the LM71 due to the limited registers of the device. 

 

2)File->Save Reg 

This saves the register display values to the specified file. 

NOTE: This menu item is not implemented for the LM71 due to the limited registers of the device. 

 

3)File->Select Plot 

This allows modification of the plot windows shown by “Start Plot”.  The dialog shows one tab for each plot 

window, along with the selected value registers to plot in that window. The “Select All” and “Select None” 

buttons allow selection of all or none of the displayed registers. The “Disable Plot” button disables this window 

from display. The “Add Plot” button adds a new plot window of the same type as the current tab; this allows 

multiple values to be spread over more windows if desired. The “Delete Plot” button is disabled until a new plot 

window is added; then the button may be used to delete the new window. The “Exit” button allows the dialog to 

be closed; a dialog prompts for saving the changes or not. The plot selections are saved upon program exit or 

selection of another device. 

NOTE: This menu item is not implemented for the LM71 due to the limited registers of the device. 

 

4)File->Set Read Time 

This sets the number of seconds between value register reads when "Read Cont" and/or ”Start Log” and/or 

”Start Plot” is selected. Tenths of seconds may be entered. A minimum time of 0.1 second and a maximum of 1 

second are allowed. This time should be set greater than the conversion time of the device, else duplicate entries 

may be read. This time is saved upon program exit or selection of another device. 

NOTE: For most accurate timing, avoid any window operations while the continuous registers reads are 

occurring. 

 

5)File->Set Log Limit 

This limits the number of data lines captured in a log file. When the limit is reached, the logging will terminate. 

If the log limit is “none”, continuous logging is enabled. This limit is saved upon program exit or selection of 

another device. 

 

5)File->View Log 

This allows a log file generated by “Start Log” to be viewed. If the viewed file is currently being updated by 

logging, the view will lag behind the logging by several lines. 

 

6)File->Exit 

This exits the program. If the register display has been modified, it is requested if you want to save the data. 

 

7)Device 

This allows selection of a different device. You will be prompted to select either the USB evaluation board or 

the Intel ICH interface or the no hardware (no connection) mode 

 

8)Help->About 

This displays the version number of the program 

 

9)Help->Manual 

This allows selection of this manual and the evaluation board manual for this device. 



 

 

Copyright © 2007 National Semiconductor  6/19/2009 
5/8 

 

III. Change History 
 

Version 1.2.0 vs. 1.1.0v 
1) Add support for ADC128D818 

 

Version 1.1.0v vs. 1.1.0u 
1) Add support for LM96080 

 

Version 1.1.0u vs. 1.1.0t 
1) Improve support for localization 

 

Version 1.1.0t vs. 1.1.0s 
1) Modifications to LM75 device file 

 

Version 1.1.0s vs. 1.1.0r 
1) Add support for LM75 

 

Version 1.1.0r vs. 1.1.0q 
1) Add support for LM95172 

 

Version 1.1.0q vs. 1.1.0p 
1) Add support for LM96000EVAL/NOPB 

2) Add support for LM95071EVAL/NOPB 

 

Version 1.1.0p vs. 1.1.0n 
1) Add support for LM96163NOPB 

 

Version 1.1.0n vs. 1.1.0m 
1) Add support for LM63RoHS and LM64RoHS 

 

Version 1.1.0m vs. 1.1.0d 
1) Add support for LM96063 and LM96163. 

2) Add support for TCrit signals on the LM95213, LM95214, LM95233 and LM95234. 

3) Add support for LM75 

4) Add support for LM95245 

 

Version 1.1.0d vs. 1.1.0b 
1) Add USB 2.0 support for the LM86, LM89, LM89-1, LM90, LM99, LM99-1 and LM95235 

2) Add ICH8 and 631xESB support 

3) Add Vista support, remove 98/ME support 

4) Add LM95233 and LM95234 support 

 

Version 1.1.0b vs. 1.1.0a 
1) Add LM95241 

 

Version 1.1.0a vs. 1.1.0 
1) Add LM95235 

 

Version 1.1.0 vs. 1.0.9 
1) Start of log file now displays all registers 

2) Fixed “Read Cont” to properly update register display 

3) Optional grouping of tabs is supported in register files 

 

Version 1.0.9 vs. 1.0.8 



 

 

Copyright © 2007 National Semiconductor  6/19/2009 
6/8 

1) LM73 is added 

 

Version 1.0.8 vs. 1.0.7a 
1) Changed “Read Cont” to a combo box with option of off/value registers/all registers. 

2) The “RW” attribute is now displayed as “R/W” 

3) A bug is fixed which displayed more tabs than needed when reloading a device file  

 

Version 1.0.7a vs. 1.0.6 
1) If the number of register tabs does not fit on one line, multi-row tabs are used in place of scrolling tabs 

2) Menu item to limit number of log file data lines is added 

 

Version 1.0.6 vs. 1.04b 
1) ADCS9888 and LM96000 evaluation board support is added 

2) The width of columns in the log file is changed to 16 characters to allow for long data 

3) The default maximum of values per plot is set to 6 instead of 8 

4) Version number changed to x.y.z format 

5) For LM95223/4, plot windows by default separate signed and unsigned temps 

6) The hex display is increased to allow for display of “DD” 

 

Version 1.04b vs. 1.04a 
1) LM32, LM40, LM41, and LM95221 evaluation board support is added 

 

Version 1.04a vs. 1.04 
1) The Intel ICH driver is updated for ICH5-CH (device ID 0x25a4) 

 

Version 1.04 vs. 1.03 
1) LM95071 evaluation board support is added 

2) LM95221 and LM96000 ICH support is added 

3) All files can be viewed on Open or View log 
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Version 1.03 vs. 1.02 
1) Multiple values can be plotted; the “Select Plot” menu selects which values 

2) Upon exit of the program, the plot selections and other values are saved 

3) The installation is updated to provide a cleaner install and uninstall. 

4) The “Write Changed Regs” button is renamed to “Write Regs”  

 
Version 1.02 vs. 1.01 
1) The menu items “Open Reg” and “Save Reg” are disabled for the LM71, which has limited registers 

 

Version 1.01 vs. LmxxEval 4.15 
1) The hardware documentation for the evaluation boards is added 

2) A “No Hardware” mode is added to allow software use when no evaluation board or device is present. 

Register reads/writes are disabled, with zero register values shown initially 

3) The LM64, LM89, LM89-1, LM90, LM93, LM99, LM99-1, LM95010 are added  

4) The LM63 target PWM pseudo register does not update the PWM register if the PWM Program bit in register 

4A is 0 

5) Registers are now written only once each time a value is changed in the interface 

6) All bits of a register are now written, including unused bits 

7) LmxxEval is renamed to SensorEval 

8) A plot of one temperature is shown for all devices except the LM93 on "Read Cont" 

9) Both the USB evaluation board and the Intel ICH are now supported 

 

Version 4.15 vs. 4.11 
1) A checkbox is added to enable or disable reading of the registers after a write. By default, reading is enabled. 

2) Read only registers may now be written, even if the chip does not support this. 

3) A check for the correct Manufacturer and Device ID is added 

4) A target PWM pseudo register is added to the LM63 to allow the PWM value register to track this target 

value when the PWM frequency is modified. This same target register contains an enable/disable bit for this 

function 

5) Most chips now include a plot for a single remote temperature when “Read Cont” is selected. 

 
Version 4.11 vs. 4.10 
1) The display of the unused register bits now shows the current values instead of only zero. 

2) The LM71 has the plot temperature range scale down as needed. 

3) The LM71 shows the plot only when "Read Cont" is selected. 

4) The LM71 no longer displays the shutdown register in decimal. 

 
Version 4.10 vs. 4.09 
1) The timer for logging and display update is more accurate.  

2) The LM63/LM85 have the MSB shown first for the tach registers. 

3) The LM63/LM85 have the tach scrollbar direction reversed to reflect the direction of the change in RPM 

value. 

4) The LM85 has the RPM corrected to reflect 2 pulses per revolution. 

5) The LM86/LM63 have the register reading corrected to eliminate occasional incorrect readings for 

temperature and RPM. 
 
Version 4.09 vs. 4.08 
1) The LM85 has improved descriptions for registers 28 to 2F. 

2) The LM63 has the duty cycle displayed for the PWM registers. 

3) This manual is displayed by the Help menu. 

4) The LM71 is added, including a real-time plot of temperature. 

5) “Set Read Time” is modified to use seconds instead of milliseconds. 
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Version 4.08 vs. 4.07 
1) This software allows selection of the LM63/LM85/LM86. Previously each device had its own software 

install. LMxxEval may be invoked more than once to display more than one device at the same time.  

2) The register data files are changed to a standardized format, which will allow compatibility with future 

versions. The extension is now .dat. If you used the older LM63Eval, LM85Eval, or LM86Eval to save register 

files with the extension .xml, you can move your files to version 4.08 with the following procedure: 

a) run this new LMxxEval software and select the desired device 

b) run your old software (LM85Eval, LM63Eval, or LM86Eval) 

c) use the "Open" menu to load your old register .xml file 

d) in LMxxEval, click "Read Regs" and then use the "Save Reg" menu to save the new format file 

e) repeat c) and d) until all the files are done 

 

Version 4.07 vs. 4.05 
1) The "Read Cont" checkbox is added to read and display registers every x msec, where x is determined by the 

"Set Read Msec" menu (default is 1000 msec). This same time is also used for the log file read time. 

2) The log file now only continuously reads the temperature, status and RPM. The other registers values are read 

and saved once at the start of the log. 

3) The "Write Regs" button is changed to the "Write Changed Regs" button, which is only active when there are 

modified registers to write. Only the modified registers are written by the button. If the "Write on Change" 

checkbox is checked then the "Write Changed Regs” button is only enabled for the special case of register 19 

(see 4. below) 

4) Register 19 Remote T_CRIT Limit is no longer written automatically when the "Write On Change" checkbox 

is enabled; in this case, the entry is only written when the "Write Changed Regs" button is pressed or another 

register is written. This prevents a partial value being written to the LM63 register 19 which is a write once 

register. 


